16th September 2019

Email Exchange services Cloud Exchange email hosting and VPS - poor performance

UPDATE 12:58 PM 17 SEP 2019

Cloud exchange email performance issues have been resolved and all systems are now back to normal. Please call support on 07 55282373 if you continue to have any issues.

UPDATE 8:30 AM 17 Sep 2019 We have received reports of customers being unable to send emails this morning. The issue has been identified and we are working to resolve it as quickly as possible. We will update this page once more information becomes available.

We apologise for this inconvenience and will continue to work on restoring this service.

Secure-ISS are currently investigating an issue with the Cloud Exchange email hosting system which is causing poor performance and Outlook disconnect issues. The issue is also effecting some VPS performance.

We will provide and update when the issue has been resolved or any new information is available.

We apologise for any inconvenience.