4th November 2019

Email Exchange services Cloud Exchange email hosting and VPS - poor performance

UPDATE: 5:09pm

Exchange email hosting services are now back to normal.

UPDATE: 8:00am

Secure-ISS are currently investigating an issue with the Cloud Exchange email hosting system which is causing poor performance and Outlook disconnect issues. The issue is also effecting some VPS performance.

We will provide and update when the issue has been resolved or any new information is available.

We apologise for any inconvenience.